Español Estructurado

+14

No comments posted yet

Comments

Slide 1

Lógica Computacional M.C. Juan Carlos Olivares Rojas

Slide 2

Introducción a la programación La principal razón para que las personas aprendan lenguajes de programación es utilizar la computadora como una herramienta para la resolución de problemas.

Slide 3

Construyendo Sistemas de Información Las fases del desarrollo de un S.I. - Análisis del Sistema - Diseño del Sistema - Programación - Pruebas - Conversión - Producción y Mantenimiento

Slide 4

¿Qué es un algoritmo? La creación de algoritmos se realiza durante la fase de análisis del sistema. Un algoritmo es la secuencia ordenada de pasos que conducen a la solución de un problema dado, y puede ser expresado en lenguaje natural, por ejemplo el castellano

Slide 5

Algoritmo Conjunto finito de reglas que dan una secuencia de operaciones para resolver todos los problemas de un tipo dado. De forma más sencilla, podemos decir que un algoritmo es un conjunto de pasos que nos permite obtener un dato. Algoritmo es el procedimiento o protocolo- paso por paso- que ideamos o escribimos para que se realice una tarea o para lograr objetivos o propósitos; es como un plan (ordenado, estructurado, específico, claro).

Slide 6

Algoritmo Algoritmo se define como una sucesión o serie de instrucciones, por pasos, que deben realizarse y que explica cómo deben procesarse los datos para producir sus resultados; los algoritmos deben escribirse en español o inglés, independientes de los lenguajes para programación (no mezclarlos).

Slide 7

Características de un Algoritmo Bien definido No ambiguo Finito (siempre termina) Efectivo Claridad: programación estructurada Correctitud: satisfacer especificación Cero o más entradas y una o más salidas

Slide 8

Características de un algoritmo Preciso. Indicar el orden de realización de cada paso. Definido. Si se sigue un algoritmo dos veces, se debe obtener el mismo resultado cada vez. Finito. Debe terminar el algún momento

Slide 9

Ejemplo de algoritmo

Slide 10

Algoritmo para hacer una taza de té Inicio Tomar la tetera Llenarla de agua Encender el fuego Mientras no hierva el agua Esperar Introducir una bolsa de té en la tetera Vaciar el té en la taza Fin

Slide 11

Ejemplo Construya un algoritmo para preparar “Pechugas de pollo en salsa de elote y chile poblano”: Ingredientes (para 6 personas) 3 Pechugas deshuesadas, sin piel y partidas a la mitad. 1 diente de ajo 4 gramos de pimienta negra. Sal. 6 cucharadas de aceite 5 chiles poblanos asados y limpios. ½ Taza de leche. ¼ Taza de crema ligera. 1 lata de crema de elote.

Slide 12

Ejemplo Algoritmo (Preparación): Muela el ajo, la pimienta y un poco de sal y únteselo a las pechugas. Caliente el aceite y dore las pechugas. Licue los chiles con la leche y la crema, y mézclelos con la crema de elote. En una fuente coloque las pechugas y báñelas con la mezcla anterior. Cubra el platón con papel aluminio y hornee a 200 °C, durante 15 minutos.

Slide 13

Otros ejemplos de algoritmos Las instrucciones o serie de pasos que sigues para grabar un número telefónico en tu celular. Las instrucciones que te dan para resolver un examen. Los pasos que sigues para prender el carbón para una carne asada El procedimiento que sigues para inscribirte EL procedimiento para obtener tu pasaporte La receta que sigues para preparar un pastel Los pasos para invitar a alguien al cine

Slide 14

Herramientas para hacer un algoritmo Las distintas representaciones de un algoritmo son el Pseudocódigo, el Diagrama N-S, el Diagrama de Flujo

Slide 15

Pseudocódigo Es un lenguaje de especificación de algoritmos y no puede ser ejecutado por una computadora, la ventaja del pseudocódigo es que el programador se puede concentrar en la lógica y en las estructuras de control y no preocuparse de las reglas de un lenguaje específico. Es fácil de modificar y puede ser rápidamente traducido a un lenguaje de programación. Representa acciones sucesivas en un lenguaje similar al humano.

Slide 16

Ejemplo: Algoritmo para dividir 2 números algoritmo División variables real: dividendo, divisor, resultado_división inicio Leer (dividendo, divisor) si divisor <> 0 entonces resultado_división= dividendo / divisor escribir (resultado_división) si_no escribir (‘El resultado es infinito’) fin_si fin

Slide 17

Ejercicio Realizar el siguiente algoritmo REGISTRO DE VENDEDORES. Una tienda emplea un cierto número de vendedores. La mayoría de estos empleados obtienen sus ingresos de comisiones sobre los artículos que venden, pero existen algunos empleados que obtienen su salario fijo, sin importar el tipo o cantidad de artículos que venden, más una comisión por sobre ciertos artículos. La tienda ofrece distintos tipos de mercancías, algunas de las cuales se clasifican como artículos estándar por que son de uso común y no requieren de técnicas creativas de venta; además, hay artículos que son altamente remunerados pero difíciles de vender.

Slide 18

Ejercicio Los compradores también se clasifican. Algunos se conocen como compradores regulares, pues hacen transacciones tan a menudo que no se requiere de hacerles venta creativa. Sin embargo, la mayoría de los clientes hacen pocas transacciones dentro de la tienda, y es probable que entren, compren algo y no vuelvan a ser vistos.

Slide 19

Ejercicio Si un empleado vende cualquier tipo de artículo a un cliente regular, no se da comisión alguna. Si un empleado asalariado vende un artículo extra, recibe una comisión del 10% a menos que el artículo tenga un precio mayor de $10,000, en cuyo caso recibe una comisión del 15%.

Slide 20

Ejercicio Si un empleado no asalariado vende un artículo extra a alguien que no sea un comprador regular, recibe un 15% de comisión a menos que el artículo tenga un precio mayor a $10,000 en cuyo caso recibe una comisión del 20%. Si un empleado asalariado vende un artículo estándar recibe un 3% de comisión, en caso de ser un empleado no asalariado recibe un 7%.

Slide 21

Pseudocódigo

Slide 22

Ejercicio resuelto

Slide 23

Lenguaje Estructurado Español Estructurado Para describir los procesos se utiliza el lenguaje natural. Este incluye estructuras de control como: Si Mientras Repetir-Hasta_que Según_sea- hacer

Slide 24

Español Estructurado Estructura selectiva Una estructura selectiva es aquella en que se ejecutan unas acciones u otras según se cumpla o no una determinada condición. La selección puede ser simple, doble o múltiple

Slide 25

Estructura Selectiva Simple Se evalúa la condición y si ésta da como resultado verdad se ejecuta una determinada acción o grupo de acciones; en caso contrario se saltan dicho grupo de acciones

Slide 26

Español Estructurado Estructura selectiva Pseudocódigo si <condición> entonces acción 1 fin_si

Slide 27

Español Estructurado Estructura selectiva Estructura Selectiva Doble Cuando el resultado de evaluar la condición es verdad se ejecutará una determinada acción o grupo de acciones y si el resultado es falso otra acción o grupo de acciones diferentes.

Slide 28

Español Estructurado Estructura selectiva Pseudocódigo si <condición> entonces acción 1 si_no acción 2 fin_si

Slide 29

Español Estructurado Estructura selectiva Estructura Selectiva Múltiple Se ejecutarán unas acciones u otras según el resultado que se obtenga al evaluar una expresión.

Slide 30

Español Estructurado Estructura selectiva Estructura Selectiva Múltiple Pseudocódigo según_sea <expresión> hacer <lista 1> : acción 1 <lista 2> : acción 2 . . . [si_no acción n] fin_según

Slide 31

Español Estructurado Estructura repetitiva mientras Lo que caracteriza este tipo de estructura es que las acciones del cuerpo del bucle se realizan cuando la condición es cierta. Además, se pregunta por la condición al principio, de donde se deduce que dichas acciones se podrán ejecutar de 0 a n veces.

Slide 32

Español Estructurado Estructura repetitiva Pseudocódigo mientras <expresión lógica> hacer acción fin_mientras

Slide 33

Español Estructurado Estructura repetitiva repetir-hasta_que El bucle repetir-Hasta_que es análogo al bucle mientras desde el punto de vista de que el cuerpo del bucle (acción) se ejecuta una y otra vez mientras la condición (expresión lógica) es verdadera. La diferencia entre ellos consiste en que en el bucle repetir-hasta_que, las sentencias del cuerpo se ejecutan, al menos una vez, antes de que se evalúe la expresión lógica. En otras palabras, el cuerpo del bucle siempre se ejecuta, al menos una vez, incluso aunque la expresión lógica sea falsa.

Slide 34

Español Estructurado Estructura repetitiva Pseudocódigo repetir acción hasta_que <expresión lógica>

Slide 35

Español Estructurado Estructura anidada Tanto las estructuras selectivas como las repetitivas pueden ser anidadas, e introducidas unas en el interior de las otras. Pseudocódigo si <condición1> entonces <acciónes1> si_no si <condición2> entonces <acciones2> si_no si <condición3> entonces <acciones3> si_no <accionesX> fin_si fin_si fin_si

Slide 36

Variables Lenguaje Estructurado. Inicialización de Variables Es conveniente inicializar las variables al inicio del algoritmo. Ejemplo: algoritmo calcula_total var entero: contador=0, total=0 inicio leer numero mientras contador < numero hacer contador=contador+1 total=total+contador fin_mientras fin

Slide 37

1. SIMPLE PROCESS (Secuencial) 2. IF-THEN-ELSE (Condición) Ejemplos Lenguaje estructurado SI (condición) ENTONCES …sentencia(s) SINO …sentencia(s) FIN SI …Sentencia(s) …Sentencia(s)

Slide 38

3. Estructura CASE (Selección) 4. WHILE-DO (iteración) SELECCION (variable) constante_1 : sentencia(s) constante_2 : sentencia(s) : : constante_n : sentencia(s) MIENTRAS (condicion) HACER sentencia(s) : : FIN MIENTRAS REPETIR sentencia(s) : : HASTA (condición) Ejemplos Lenguaje estructurado

Summary: Español Estructurado - Pseudocódigo

Tags: español estructurado

URL:
More by this User
Most Viewed